domenica 27 maggio 2012

IE8 misbehaves on virtualized Windows XP SP3 inside Virtual PC 7.0.2

A few months ago I subscribed to Microsoft TechNet Standard.

Today I installed Microsoft Virtual PC 7.0.2 onto my glorious PowerBook G4 1.67 GHz/1.5 GB, to test Windows XP Professional SP3.

The installation took quite a long time but in the end all went fine. Running XP on a PowerPC G4 is not the fastest experience, but acceptable anyway.

Next step, I updated Internet Explorer from version 6 to version 8.

I run IE8-WindowsXP-x86-ENU.exe, restarted the virtual machine, launched IE8, went along the first time run questionnaire. I don't like automatic updates, so I opted for not to let the system check for updates for IE.

Everything was in place. Time to test internet sites. I typed in the first URL that came to mind, hit return and waited for the page to load. I could see, on the status bar, the loading page progress, but I got nothing but a blank page. Tried a couple of other URLs. Same results.

What I discovered after some Google searches was that, I wasn't alone.
At first, the only resolutive suggestion I found was to uninstall IE8 and install IE7. I didn't like the idea. Tried harder and I came across this MacWindows.com post.

Now I knew that an IE patch would have fixed the issue. But which one?
Back to Google search engine I entered "Cumulative IE8 updates" into the search box. As expected, I got in return a plethora of links. I went for the first one in the list 


and, YES, that did the trick :-)

1 commento:

banlin mithra ha detto...

Microsoft Gold Certified partner Ilabs Technology Solutions provides desktop, server and application Virtualization services and can manage the daily monitoring and management tasks of your IT infrastructure.